CVE-2026-118984: cheaper-inference OmniRoute · Unverified Password Change
Affects cheaper-inference OmniRouteSource CVE Database V5
Not known to be exploited · CVSS 7.0 High : upgrade to 3.8.52 soon.
Data as of 29 Oct 2026, 11:03 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.0 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.5 |
- Patch
- Available – fixed in 3.8.52
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cheaper-inference OmniRoute to 3.8.52.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| cheaper-inferenceOmniRoute | Affected
| Fixed in
|
npmOmniRoutepkg:npm/OmniRouteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OmniRoute to version 3.8.52 or later, where this vulnerability is fixed. No other mitigations are specified or required once the patch is applied.
Description
OmniRoute versions 3.8.0 through 3.8.51 contain a vulnerability that allows holders of manage- or admin-scoped API keys or oma_ access tokens to change the management password without verifying the current password. This can enable attackers to lock out legitimate operators, take over dashboard login, or disable login requirements entirely. The issue is fixed in version 3.8.52.
References
- github.com/cheaper-inference/OmniRoute/pull/16897 (opens in a new tab)
- github.com/cheaper-inference/OmniRoute/commit/dde27f4964872c9b43cfd5b8f532693f6c018af6 (opens in a new tab)
- github.com/cheaper-inference/OmniRoute/blob/c1e30b7676975feb298b49eff6ff58923c04b89e/src/app/api/settings/require-login/route.ts (opens in a new tab)
- github.com/cheaper-inference/OmniRoute/blob/c1e30b7676975feb298b49eff6ff58923c04b89e/src/app/api/settings/route.ts (opens in a new tab)
- github.com/cheaper-inference/OmniRoute/releases/tag/v3.8.52 (opens in a new tab)
- github.com/cheaper-inference/OmniRoute (opens in a new tab)
- vulncheck.com/advisories/omniroute-3.8.0-before-3.8.52-unverified-password-change-via-api-settings-require-login (opens in a new tab)