CVE-2026-119025: sindresorhus open · OS Command Injection
Affects sindresorhus openSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 11.0.0 soon.
Data as of 29 Oct 2026, 11:47 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 11.0.0, 2.12.0, 1.18.33
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade open to 11.0.0; inspector to 2.12.0; opencode to 1.18.33.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| sindresorhusopen | Affected
| Fixed in
|
| modelcontextprotocolinspector | Affected
| Fixed in
|
| anomalycoopencode | Affected
| Fixed in
|
npmopenpkg:npm/openOther threats | Affected
| Fixed in
|
npminspectorpkg:npm/inspectorOther threats | Affected
| Fixed in
|
npmopencodepkg:npm/opencodeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to open version 11.0.0 or later, or to versions 2.12.0 or 1.18.33 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Applying the official fix fully addresses the issue.
Description
open versions from 7.2.0 up to but not including 11.0.0 contain an OS command injection vulnerability on Windows and WSL. This flaw allows attackers to execute arbitrary PowerShell commands by supplying specially crafted URLs that include $(...) subexpressions. The vulnerability arises because these URLs are passed unescaped to powershell -EncodedCommand in index.js, enabling code execution. Fixed versions are 11.0.0 and later.
References
- github.com/sindresorhus/open/commit/274d70446bf38a7b7d50b214dd3962ef8ea9320d (opens in a new tab)
- github.com/sindresorhus/open/releases/tag/v11.0.0 (opens in a new tab)
- github.com/sindresorhus/open/blob/v10.2.0/index.js (opens in a new tab)
- github.com/sindresorhus/open/blob/v7.2.0/index.js (opens in a new tab)
- github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw (opens in a new tab)
- github.com/anomalyco/opencode/pull/51414 (opens in a new tab)
- github.com/anomalyco/opencode/commit/29f07e0c69ad8668e0e15b0eb54f2fcb342af98c (opens in a new tab)
- vulncheck.com/advisories/open-7.2.0-before-11.0.0-os-command-injection-via-powershell-on-windows (opens in a new tab)