Skip to main content
VulnerabilityPublished

CVE-2026-119027: oapi-codegen · Code Injection

Affects oapi-codegenSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 2.8.1 soon.

Data as of 29 Oct 2026, 12:02 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 2.8.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade oapi-codegen to 2.8.1.

Affected software

ProductAffectedFixed in
oapi-codegenoapi-codegenAffected
  • >=2.5.0 <2.8.1
Fixed in
  • 2.8.1
Gooapi-codegenpkg:golang/oapi-codegenOther threatsAffected
  • >=2.5.0 <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade oapi-codegen to version 2.8.1 or later, where this vulnerability is fixed. There are no vendor advisories indicating alternative mitigations or that no action is required.

Description

oapi-codegen versions 2.5.0 through 2.8.0 contain a code injection vulnerability. This flaw allows attackers who control an OpenAPI document to inject arbitrary Go code via the servers[].x-go-name field, which is emitted unescaped in the server-urls template. The injected code can include a func init() that executes when the victim builds and imports the generated package. The vulnerability is fixed in version 2.8.1.

References

Community reviews

Loading reviews…