CVE-2026-119143: bytecodealliance wasmtime · Improper Validation of Array Index
Affects bytecodealliance wasmtimeSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 49.0.3 or 48.0.6 when convenient.
Data as of 29 Oct 2026, 16:23 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.8 |
- Patch
- Available – fixed in 49.0.3, 48.0.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade bytecodealliance wasmtime to 49.0.3 or 48.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bytecodealliancewasmtime | Affected
| Fixed in
|
| bytecodealliancewasmtime | Affected
| Fixed in
|
crates.iowasmtimepkg:cargo/wasmtimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions 48.0.6 and 49.0.3 are available. Users should upgrade to at least these versions to remediate the vulnerability. No other mitigations are indicated.
Description
CVE-2026-119143 is a denial of service vulnerability in bytecodealliance's wasmtime affecting versions 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3. The flaw allows guest code to cause a host panic by performing out-of-bounds zero-length stream operations, leading to a crash in WASIp3 embedders.