Skip to main content
VulnerabilityPublished

CVE-2026-119379: SQLite · Out-of-bounds Write

Affects SQLiteSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 3.54.0 soon.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 3.54.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade SQLite to 3.54.0.

Affected software

ProductAffectedFixed in
SQLiteSQLiteAffected
  • <3.54.0
Fixed in
  • 3.54.0
GitHubSQLitepkg:github/SQLiteOther threatsAffected
  • <3.54.0
Fixed in
  • 3.54.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected SQLite installations to version 3.54.0 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Applying this official fix fully addresses the issue.

Description

SQLite versions prior to 3.54.0 that are built with the session extension contain a heap buffer overflow vulnerability in the sqlite3changeset_apply() function. This flaw allows attackers to corrupt heap memory by crafting changesets that repeat a table name with a larger column count, causing a buffer overflow in sessionUpdateFind(). The vulnerability is fixed in version 3.54.0.

References

Community reviews

Loading reviews…