Skip to main content
VulnerabilityPublished

CVE-2026-119422: juspay hyperswitch · Insufficient Verification of Data Authenticity

Affects juspay hyperswitchSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 2026.10.01.0 or 1.128.0 soon.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
Patch
Available – fixed in 2026.10.01.0, 1.128.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade juspay hyperswitch to 2026.10.01.0 or 1.128.0.

Affected software

ProductAffectedFixed in
juspayhyperswitchAffected
  • <2026.10.01.0
Fixed in
  • 2026.10.01.0
juspayhyperswitchAffected
  • <1.128.0
Fixed in
  • 1.128.0
GitHubhyperswitchpkg:github/hyperswitchOther threatsAffected
  • <1.128.0
  • <2026.10.01.0
Fixed in
  • 1.128.0
  • 2026.10.01.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Juspay Hyperswitch versions 1.128.0 and 2026.10.01.0. Users should upgrade to these versions or later to remediate the vulnerability. There is no indication that the vulnerability is mitigated by configuration or that no action is required.

Description

Juspay Hyperswitch versions before 1.128.0 contain an authentication bypass vulnerability in the Worldpayxml connector. The verify_webhook_source function always returns true without enforcing mutual TLS, allowing unauthenticated attackers who know the merchant_id and Worldpay orderCode to forge payment status updates. This can result in marking unpaid payments as charged or triggering refund, dispute, and payout events.

References

Community reviews

Loading reviews…