Skip to main content
VulnerabilityPublished

CVE-2026-11945: DALIBO PostgreSQL Anonymizer · SQL Injection

Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium : upgrade to 3.1.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.1.1.

Affected software

ProductAffectedFixed in
DALIBOPostgreSQL AnonymizerAffected
  • >=1 <3.1.1
Fixed in
  • 3.1.1
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threatsAffected
  • <3.1.1
Fixed in
  • 3.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PostgreSQL Anonymizer to version 3.1.1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is documented. Users should avoid invoking import_database_rules() or import_roles_rules() with untrusted JSON documents until patched.

Description

PostgreSQL Anonymizer versions prior to 3.1.1 contain an SQL injection vulnerability that allows privilege escalation to superuser. The vulnerability occurs when a superuser calls import_database_rules() or import_roles_rules() with a crafted JSON document containing malicious code in a key-value pair. This code executes with superuser privileges. The issue is fixed in version 3.1.1 and later.

References

Community reviews

Loading reviews…