Skip to main content
VulnerabilityPublished

CVE-2026-119598: iluobei miaomiaowu · Insecure Direct Object Reference

Affects iluobei miaomiaowuSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.9.3 when convenient.

Data as of 30 Oct 2026, 13:48 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 0.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade iluobei miaomiaowu to 0.9.3.

Affected software

ProductAffectedFixed in
iluobeimiaomiaowuAffected
  • <0.9.3
Fixed in
  • 0.9.3
GitHubmiaomiaowupkg:github/miaomiaowuOther threatsAffected
  • <0.9.3
Fixed in
  • 0.9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Miaomiaowu before 0.9.3 contains an insecure direct object reference vulnerability in /api/user/proxy-provider-configs that allows authenticated users to read other users' configurations. Attackers can iterate the global auto-increment external_subscription_id parameter to disclose override scripts, filter rules, custom request headers and health-check URLs.

References

Community reviews

Loading reviews…