Skip to main content
VulnerabilityPublished

CVE-2026-119662: songloft · Use of Hard-coded Credentials

Affects songloftSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.13.6 soon.

Data as of 30 Oct 2026, 15:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 2.13.6
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade songloft to 2.13.6.

Affected software

ProductAffectedFixed in
songloft-orgsongloftAffected
  • >=2.9.0 <2.13.6
Fixed in
  • 2.13.6
GitHubsongloftpkg:github/songloftOther threatsAffected
  • >=2.9.0 <2.13.6
Fixed in
  • 2.13.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Songloft to version 2.13.6 or later, where the hardcoded credentials vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

Songloft versions 2.9.0 up to but not including 2.13.6 contain a vulnerability due to hardcoded administrator credentials (admin/admin). This flaw allows attackers on the same network to authenticate as an administrator via the /api/v1/auth/login endpoint. Exploitation enables modification of library and configuration settings and installation of JavaScript plugins running in QuickJS. The vulnerability has a high severity with a CVSS 4.0 score of 8.7. The issue is fixed in version 2.13.6.

References

Community reviews

Loading reviews…