Skip to main content
VulnerabilityPublished

CVE-2026-119720: Blender · Out-of-bounds Read

Affects BlenderSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 5.2.3 or 4.5.15 when convenient.

Data as of 30 Oct 2026, 16:18 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.8
CNA (VulnCheck)CVSS 3.15.5
Patch
Available – fixed in 5.2.3, 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Blender to 5.2.3 or 4.5.15.

Affected software

ProductAffectedFixed in
Blender FoundationBlenderAffected
  • >=5.0.0 <5.2.3
Fixed in
  • 5.2.3
Blender FoundationBlenderAffected
  • <4.5.15
Fixed in
  • 4.5.15

AI-suggested

Users should update Blender to version 4.5.15 or later, or 5.2.3 or later, where this vulnerability is fixed. Applying these official fixes will remediate the issue. No additional mitigation steps are indicated.

Description

CVE-2026-119720 is a heap out-of-bounds read vulnerability in Blender versions before 4.5.15 and 5.x before 5.2.3. It occurs in the read_file_dna() function when processing a crafted .blend file with a truncated GLOB block, leading to a crash.

References

Community reviews

Loading reviews…