CVE-2026-119757: BTCPay Server · Exposed Files or Directories
Affects BTCPay ServerSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.4.2 as a priority.
Data as of 5 Nov 2026, 22:05 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 2.4.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade BTCPay Server to 2.4.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BTCPay ServerBTCPay Server | Affected
| Fixed in
|
GitHubBTCPay Serverpkg:github/BTCPay ServerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade BTCPay Server to version 2.4.2 or later, where this vulnerability is fixed. No other mitigation is required as the fix fully addresses the issue.
Description
BTCPay Server versions before 2.4.2, including 2.4.2 release candidates, have an information disclosure vulnerability that allows unauthenticated remote attackers to access .macaroon credential files for an LND node. These credentials can be used to gain full control over the Lightning Network Daemon node, including the ability to move funds, potentially leading to theft. The vulnerability is fixed in version 2.4.2.