Skip to main content
VulnerabilityPublished

CVE-2026-119842: Red Hat Enterprise Linux 10 gstreamer1-plugins-base · NULL Pointer Dereference

Affects Red Hat Enterprise Linux 10 gstreamer1-plugins-baseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade the Red Hat redhat/gstreamer1-plugins-base package to 1.28.2 when convenient.

Data as of 30 Oct 2026, 20:38 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.16.5
Patch
Available – fixed in 1.28.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Red Hat redhat/gstreamer1-plugins-base package to 1.28.2.

Affected software

ProductAffectedFixed in
Red Hatredhat/gstreamer1-plugins-basepkg:rpm/redhat/gstreamer1-plugins-baseOther threatsAffected
  • <1.28.2
Fixed in
  • 1.28.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available upstream in gst-plugins-base version 1.28.2 and later. Fedora 44 and Fedora Rawhide include the fixed version 1.28.8 and are not affected. Red Hat Enterprise Linux users should upgrade to a version including the fix when available. In the meantime, users should avoid opening untrusted MicroDVD (.sub) subtitle files and disable automatic subtitle loading if the media player supports this feature.

Description

CVE-2026-119842 is a moderate severity vulnerability in the GStreamer gst-plugins-base MicroDVD subtitle parser used in Red Hat Enterprise Linux 10. The flaw causes a NULL pointer dereference when processing a specially crafted MicroDVD (.sub) subtitle file, leading to a crash of the media player application. Exploitation requires user interaction by opening or playing media with a malformed subtitle file. The impact is limited to denial of service with no confidentiality or integrity loss. Versions of gstreamer1-plugins-base prior to 1.28.2 are affected; Fedora 43 is affected, while Fedora 44 and later include the fix. Mitigation includes avoiding untrusted subtitle files and disabling automatic subtitle loading if possible.

References

Community reviews

Loading reviews…