CVE-2026-120062: PostgreSQL psqlODBC · SQL Injection
Affects PostgreSQL psqlODBCSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 18.00.0006 soon.
Data as of 2 Nov 2026, 19:58 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade PostgreSQL psqlODBC to 18.00.0006.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQLpsqlODBC | Affected
| Fixed in
|
GitHubpsqlODBCpkg:github/psqlODBCOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to psqlODBC version 18.00.0006 or later, where this vulnerability is fixed. No other mitigation is indicated or required as the fix addresses the root cause.
Description
A SQL injection vulnerability exists in the SQLSpecialColumns function of psqlODBC before version 18.00.0006. This function improperly concatenates table and schema names into its catalog query without escaping, allowing an attacker who can supply untrusted input to execute arbitrary SQL commands with the connection's privileges.