Skip to main content
VulnerabilityPublished

CVE-2026-120063: PostgreSQL psqlODBC · Stack-based Buffer Overflow

Affects PostgreSQL psqlODBCSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 18.00.0006 when convenient.

Data as of 2 Nov 2026, 19:58 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.15.9
Patch
Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade PostgreSQL psqlODBC to 18.00.0006.

Affected software

ProductAffectedFixed in
PostgreSQLpsqlODBCAffected
  • <18.00.0006
Fixed in
  • 18.00.0006
GitHubpsqlODBCpkg:github/psqlODBCOther threatsAffected
  • <18.00.0006
Fixed in
  • 18.00.0006

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version, 18.00.0006, is available and should be applied to remediate this vulnerability. Users should upgrade psqlODBC to version 18.00.0006 or later. Until patched, avoid forwarding untrusted SQL text to the driver to reduce exposure.

Description

CVE-2026-120063 is a stack-based buffer overflow vulnerability in the PostgreSQL psqlODBC driver. It occurs when quoting schema or table names into a fixed 128-byte stack buffer, allowing writes up to two bytes beyond the buffer's end for long names. This overflow can corrupt the stack with a double quote and a null byte. The vulnerability affects versions before 18.00.0006 and arises from parsing SQL text that includes untrusted schema or table names. Exploitation requires forwarding untrusted SQL text to the driver.

References

Community reviews

Loading reviews…