Skip to main content
VulnerabilityPublished

CVE-2026-120091: Temporal Server · OS Command Injection

Affects Temporal ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.32.2 or 1.31.5 soon.

Data as of 2 Nov 2026, 21:43 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Temporal)CVSS 4.08.7
Patch
Available – fixed in 1.32.2, 1.31.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Temporal Server and go.temporal.io/server to 1.32.2 or 1.31.5.

Affected software

ProductAffectedFixed in
Temporal Servergo.temporal.io/serverAffected
  • >=1.32.0 <1.32.2
Fixed in
  • 1.32.2
Temporal Servergo.temporal.io/serverAffected
  • >=1.31.0 <1.31.5
Fixed in
  • 1.31.5
Gogo.temporal.io/serverpkg:golang/go.temporal.io/serverOther threatsAffected
  • >=1.31.0 <1.31.5
  • >=1.32.0 <1.32.2
Fixed in
  • 1.31.5
  • 1.32.2

CPE configurations (1)

  • cpe:2.3:a:temporal:temporal:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Deployments should upgrade Temporal Server to version 1.31.5 or later in the 1.31 line, or 1.32.2 or later in the 1.32 line, where the vulnerability is fixed. Additionally, ensure the dynamic configuration setting workercontroller.compute_providers.enabled does not include 'k8s' unless explicitly required and properly secured. For versions 1.31.0 through 1.31.2, where the allowlist is disabled by default, explicitly configure the allowlist to exclude 'k8s' to prevent exposure. Verify that authorization is properly configured to restrict access to the ValidateWorkerDeploymentVersionComputeConfig operation, especially for callers without namespace write access. Deployments using custom authorizers should confirm these do not permit unauthorized access to this operation. The workercontroller.enabled setting does not mitigate this vulnerability and should not be relied upon.

Description

Temporal Server versions 1.31.0 through 1.31.4 and 1.32.0 through 1.32.1 include a command injection vulnerability in the Kubernetes compute provider of the Worker Controller Instance module. This vulnerability allows an authenticated user with read-only namespace access to execute arbitrary commands on the Worker Service host, potentially impacting the entire Kubernetes cluster due to the server's elevated credentials. The issue arises because the Kubernetes client is built from caller-supplied configuration without proper restrictions. The vulnerability is mitigated by a compute provider allowlist setting that denies access to the k8s provider by default starting in versions 1.31.3 and 1.32.0, but earlier affected versions have this allowlist disabled by default, exposing stock deployments. Fixed versions are 1.31.5 and 1.32.2.

References

Community reviews

Loading reviews…