CVE-2026-120308: beam-cloud Beta9 gateway · Path Traversal
Affects beam-cloud Beta9 gatewaySource CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 0.1.776 as a priority.
Data as of 1 Nov 2026, 13:14 UTC
Thin evidence
One scorer or none| CNA (JFROG) | CVSS 3.1 | 9.9 |
|---|
- Patch
- Available – fixed in 0.1.776, 0.1.756
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Beta9 gateway to 0.1.776; Beta9 worker to 0.1.756; github.com/beam-cloud/beta9 to 0.1.776 or 0.1.756.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Beta9 gatewaygithub.com/beam-cloud/beta9 | Affected
| Fixed in
|
| Beta9 workergithub.com/beam-cloud/beta9 | Affected
| Fixed in
|
GitHubgithub.com/beam-cloud/beta9pkg:github/github.com/beam-cloud/beta9Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerability has been fixed in gateway version 0.1.776 and worker version 0.1.756. Users should upgrade to these or later versions to ensure volume identifiers and mount paths are properly validated and unauthorized volumes are rejected. No additional mitigation is required once these versions are deployed.
Description
CVE-2026-120308 is a critical path traversal vulnerability in the beam-cloud Beta9 gateway that allows a tenant with a workspace token to read and write arbitrary files on the worker's filesystem. This occurs because the gateway improperly validates volume identifiers when attaching volumes during function, endpoint, or task queue deployment. The vulnerability affects gateway versions prior to 0.1.776 and worker versions prior to 0.1.756. The issue has been fixed by validating volume identifiers and mount paths and rejecting unauthorized volumes.
References
- github.com/beam-cloud/beta9 (opens in a new tab)
- github.com/beam-cloud/beta9/pull/1897 (opens in a new tab)
- github.com/beam-cloud/beta9/commit/a28bf12cf0007c792a25d8ed282b4e8bf6f30393 (opens in a new tab)
- github.com/beam-cloud/beta9/releases/tag/gateway-0.1.776 (opens in a new tab)
- github.com/beam-cloud/beta9/releases/tag/worker-0.1.756 (opens in a new tab)
- github.com/beam-cloud/beta9/releases/tag/gateway-0.1.769 (opens in a new tab)
- github.com/beam-cloud/beta9/releases/tag/worker-0.1.745 (opens in a new tab)