Skip to main content
VulnerabilityPublished

CVE-2026-120312: Jovancoding Network-AI · Relative Path Traversal

Affects Jovancoding Network-AISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 5.15.5 soon.

Data as of 2 Nov 2026, 02:58 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 5.15.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade Jovancoding Network-AI to 5.15.5.

Affected software

ProductAffectedFixed in
JovancodingNetwork-AIAffected
  • >=5.13.4 <5.15.5
Fixed in
  • 5.15.5
npmNetwork-AIpkg:npm/Network-AIOther threatsAffected
  • >=5.13.4 <5.15.5
Fixed in
  • 5.15.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Network-AI to version 5.15.5 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

Network-AI versions from 5.13.4 up to but not including 5.15.5 contain a relative path traversal vulnerability in the AgentVCR component. This flaw allows attackers who can control the cassette name parameter to read or write arbitrary JSON files by passing traversal sequences to the load() or save() functions. Exploitation can lead to disclosure of sensitive JSON data or overwriting critical policy files such as AuthGuardian trust-level configurations. The vulnerability is fixed in version 5.15.5.

References

Community reviews

Loading reviews…