Skip to main content
VulnerabilityPublished

CVE-2026-120416: AndyFactory newspaper4k · Server-Side Request Forgery

Affects AndyFactory newspaper4kSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium.

Data as of 2 Nov 2026, 18:29 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.06.9
CNA (VulDB)CVSS 3.15.3
CNA (VulDB)CVSS 3.05.3
CNA (VulDB)CVSS 2.05.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
AndyFactorynewspaper4kAffected
  • 0.9.0 – 0.9.6
7 affected builds
Fixed in–
PyPInewspaper4kpkg:pypi/newspaper4kOther threatsAffected
  • 0.9.0 – 0.9.6
7 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:andyfactory:newspaper4k:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected installations of AndyFactory newspaper4k to version 0.9.6.1 or later, which contains the official fix for this SSRF vulnerability. The vendor has released this patch promptly after disclosure, and upgrading is the recommended remediation step.

Description

CVE-2026-120416 is a server-side request forgery (SSRF) vulnerability in the AndyFactory newspaper4k software affecting versions 0.9.0 through 0.9.6. The flaw exists in the Article.parse function within the image_extractor.py component. This vulnerability allows remote attackers to manipulate the server to make unauthorized requests. The issue is resolved by upgrading to version 0.9.6.1.

References

Community reviews

Loading reviews…