Skip to main content
VulnerabilityPublished

CVE-2026-120499: h5io · Eval Injection

Affects h5ioSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 0.2.6 soon.

Data as of 5 Nov 2026, 17:04 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 0.2.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade h5io to 0.2.6.

Affected software

ProductAffectedFixed in
h5ioh5ioAffected
  • >=0.1.0 <0.2.6
Fixed in
  • 0.2.6
PyPIh5iopkg:pypi/h5ioOther threatsAffected
  • >=0.1.0 <0.2.6
Fixed in
  • 0.2.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade h5io to version 0.2.6 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Applying this official fix fully addresses the issue.

Description

CVE-2026-120499 is a code injection vulnerability in the h5io library versions before 0.2.6. It arises from improper neutralization of directives in dynamically evaluated code within the read_hdf5() function. Attackers can craft malicious HDF5 files that execute arbitrary Python code via eval() or by importing arbitrary modules or deserializing pickled objects. This vulnerability has a high severity rating and is fixed in version 0.2.6.

References

Community reviews

Loading reviews…