Skip to main content
VulnerabilityPublished

CVE-2026-120503: EchoHS GeekezBrowser · Information Disclosure

Affects EchoHS GeekezBrowserSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium · fixed in 1.8.1 : patch EchoHS GeekezBrowser as a priority.

Data as of 2 Nov 2026, 20:58 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.04.8
CNA (VulDB)CVSS 3.13.3
CNA (VulDB)CVSS 3.03.3
CNA (VulDB)CVSS 2.01.7
Patch
Available – fixed in 1.8.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
EchoHSGeekezBrowserAffected
  • 1.0 – 1.8.0
12 affected builds
Fixed in–
GitHubechohs/GeekezBrowserpkg:github/echohs/GeekezBrowserOther threatsAffected
  • 1.0 – 1.8.0
12 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:echohs:geekezbrowser:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade EchoHS GeekezBrowser to version 1.8.1 or later, which contains the official fix for this vulnerability. No other mitigation is indicated or required.

Description

CVE-2026-120503 is an information disclosure vulnerability in EchoHS GeekezBrowser versions up to 1.8.0 affecting the /api/status endpoint of the Public API component. The flaw requires local access to exploit and can lead to unauthorized information disclosure. A public exploit exists. Upgrading to version 1.8.1 mitigates the issue.

References

Community reviews

Loading reviews…