CVE-2026-120551: WP Compress – Instant Performance & Speed Optimization · Missing Authorization
Affects WP Compress – Instant Performance & Speed OptimizationSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium.
Data as of 3 Nov 2026, 05:13 UTC
Thin evidence
One scorer or none| CNA (Wordfence) | CVSS 3.1 | 5.3 |
|---|
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| aresitWP Compress – Instant Performance & Speed Optimization | Affected
| Fixed in– |
AI-suggested
Users should upgrade beyond version 7.22.01 once a fix is released. Until then, avoid using fresh or lite/free-mode installations without an api_key. Monitor vendor advisories for official remediation guidance. Since this is not a cloud service, remediation depends on plugin updates from the vendor.
Description
The WP Compress – Instant Performance & Speed Optimization WordPress plugin contains an authorization bypass vulnerability in all versions up to and including 7.22.01. This flaw allows unauthenticated attackers to link a victim site to an attacker-controlled WP Compress account and overwrite plugin settings. The vulnerability arises because the plugin does not properly verify user authorization, especially in fresh or lite/free-mode installations without an existing api_key. Exploitation enables attackers to gain the shared api_key, granting control over cache purging, file deletion, opcode cache invalidation, and other privileged operations.
References
- wordfence.com/threat-intel/vulnerabilities/id/42d4ec8b-d3ed-4aa3-a8b9-cddaf64a7531?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/7.21.27/classes/mainwp.class.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/7.21.27/classes/mainwp.class.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/7.21.27/classes/connect.class.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?reponame=&old=3680035%40wp-compress-image-optimizer&new=3680035%40wp-compress-image-optimizer (opens in a new tab)