CVE-2026-120575: Photo Engine (Media Organizer & Lightroom) (WordPress plugin) · Cross-site Scripting
Affects Photo Engine (Media Organizer & Lightroom) (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium.
Data as of 3 Nov 2026, 05:13 UTC
Thin evidence
One scorer or none| CNA (Wordfence) | CVSS 3.1 | 6.4 |
|---|
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| tigroumeowPhoto Engine (Media Organizer & Lightroom) | Affected
| Fixed in– |
AI-suggested
Users should upgrade beyond version 6.5.7 when a fix is released. Until then, restrict subscriber-level access if possible and monitor for plugin updates. Because the vulnerability relies on authentication tokens exposed in admin pages and lack of capability checks, reviewing and hardening access controls and token handling may reduce risk.
Description
The Photo Engine (Media Organizer & Lightroom) WordPress plugin is vulnerable to stored cross-site scripting (XSS) via the 'hierarchy[].name' parameter in all versions up to and including 6.5.7. Authenticated users with subscriber-level access or higher can inject malicious scripts that execute when other users view the affected pages. This is enabled by insufficient input sanitization and output escaping, combined with an authentication mechanism that relies solely on a usermeta token without capability checks and exposure of the token on admin pages.
References
- wordfence.com/threat-intel/vulnerabilities/id/ebb6a31a-3d12-4dd1-b9f8-5d9e17f0bf48?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/explorer.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/core.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/core.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/api.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/api.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wplr-sync/tags/6.5.6/classes/admin.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?old_path=/wplr-sync/tags/6.5.6&new_path=/wplr-sync/tags/6.5.8 (opens in a new tab)