Skip to main content
VulnerabilityPublished

CVE-2026-120597: Welcart e-Commerce Plugin · Cross-site Scripting

Affects Welcart e-Commerce PluginSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium · fixed in 2.12.7 : patch Welcart e-Commerce Plugin as a priority.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.14.3
CNA (VulDB)CVSS 3.04.3
CNA (VulDB)CVSS 2.05.0
Patch
Available – fixed in 2.12.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Welcarte-Commerce PluginAffected
  • 2.12.0 – 2.12.6
7 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:welcart:e-commerce_plugin:*:*:*:*:*:*:*:*

AI-suggested

Upgrade the Welcart e-Commerce Plugin to version 2.12.7 or later, where the vulnerability is fixed by proper escaping of the ResponseCd value using esc_html(). This is the official and recommended remediation. No additional mitigation actions are indicated by the vendor.

Description

CVE-2026-120597 is a cross-site scripting (XSS) vulnerability in the Welcart e-Commerce Plugin for WordPress, affecting versions 2.12.0 through 2.12.6. The flaw exists in the ESCOTT_MAIN::error_page_message function in the file classes/paymentESCOTT.main.class.php, where the ResponseCd argument is not properly escaped. This allows remote attackers to inject malicious scripts. The issue is fixed in version 2.12.7 by escaping the value with esc_html() before output.

References

Community reviews

Loading reviews…