Skip to main content
VulnerabilityPublished

CVE-2026-120833: NIST labbench · Deserialization of Untrusted Data

Affects NIST labbenchSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 0.46.1 soon.

Data as of 3 Nov 2026, 00:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 0.46.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade NIST labbench to 0.46.1.

Affected software

ProductAffectedFixed in
NISTlabbenchAffected
  • <0.46.1
Fixed in
  • 0.46.1
PyPIlabbenchpkg:pypi/labbenchOther threatsAffected
  • <0.46.1
Fixed in
  • 0.46.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade labbench to version 0.46.1 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

NIST labbench versions before 0.46.1 contain a deserialization of untrusted data vulnerability in the read() and read_relational() functions. These functions pass any file with a .p or .pickle extension to pandas.read_pickle based solely on the file extension, allowing attackers to execute arbitrary code by supplying crafted data files. This vulnerability is fixed in version 0.46.1.

References

Community reviews

Loading reviews…