CVE-2026-120843: Posts Table with Search & Sort (WordPress plugin) · Cross-site Scripting
Affects Posts Table with Search & Sort (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.4.15 when convenient.
Data as of 3 Nov 2026, 18:14 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 1.4.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Posts Table with Search & Sort (WordPress plugin) to 1.4.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Posts Table with Search & Sortposts-data-table | Affected
| Fixed in
|
AI-suggested
Users should upgrade to version 1.4.15 or later of the Posts Table with Search & Sort plugin where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-120843 is a stored cross-site scripting (XSS) vulnerability in Barn2 Plugins' Posts Table with Search & Sort plugin. It affects versions from initial releases up to 1.4.14. The vulnerability allows improper neutralization of input during web page generation, potentially enabling attackers to inject malicious scripts. A fix is available in version 1.4.15.