CVE-2026-121409: FreeRDP · Reachable Assertion
Affects FreeRDPSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 3.32.2 soon.
Data as of 3 Nov 2026, 14:59 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade FreeRDP and freerdp/FreeRDP to 3.32.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreeRDPFreeRDP | Affected
| Fixed in
|
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FreeRDP to version 3.32.2 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Applying the official patch fully resolves the issue.
Description
FreeRDP versions before 3.32.2 contain a denial of service vulnerability caused by reachable assertions triggered by oversized X.224 routing tokens. Malicious servers or unauthenticated peers can exploit this by sending oversized LoadBalanceInfo in a Server Redirection PDU or a 240–247 byte token to a FixedTarget freerdp-proxy, causing the client or proxy process to crash.