CVE-2026-121414: parse-server · Uncaught Exception
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 9.10.6-alpha.2 soon.
Data as of 3 Nov 2026, 14:43 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 9.10.6-alpha.2, 8.6.110
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade parse-server to 9.10.6-alpha.2; parse-server to 8.6.110; parse-server to 9.10.6-alpha.2 or 8.6.110.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object update uses a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. Attackers, including unauthenticated clients when objects are writable without a session, can send such an update to crash the Node process.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv (opens in a new tab)
- github.com/parse-community/parse-server/pull/10802 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10803 (opens in a new tab)
- vulncheck.com/advisories/parse-server-before-8.6.110-and-9.0.0-before-9.10.6-alpha.2-denial-of-service-via-aftersave-pointer-update (opens in a new tab)