CVE-2026-121560: logchimp · Insecure Direct Object Reference
Affects logchimpSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.9.3 soon.
Data as of 3 Nov 2026, 15:28 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.1 |
- Patch
- Available – fixed in 0.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade logchimp to 0.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| logchimplogchimp | Affected
| Fixed in
|
GitHublogchimppkg:github/logchimpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
LogChimp 0.9.0-alpha.1 before 0.9.3 contains an authorization bypass vulnerability that allows authenticated post authors to modify any other post by supplying mismatched postId and id body parameters. Attackers can set postId to their own post and id to an enumerated victim post UUID to overwrite its title, slug, content, boardId and roadmap_id.
References
- github.com/logchimp/logchimp/commit/a78b69af342908472ad400285187e43729295a7c (opens in a new tab)
- github.com/logchimp/logchimp (opens in a new tab)
- github.com/logchimp/logchimp/blob/v0.9.2/packages/server/src/controllers/post/updatePost.ts (opens in a new tab)
- github.com/logchimp/logchimp/blob/v0.9.2/packages/server/src/middlewares/postExists.ts (opens in a new tab)
- github.com/logchimp/logchimp/releases/tag/v0.9.3 (opens in a new tab)
- vulncheck.com/advisories/logchimp-before-0.9.3-authorization-bypass-via-patch-api-v1-posts (opens in a new tab)