Skip to main content
VulnerabilityPublished

CVE-2026-121588: texlyre · Cross-site Scripting

Affects texlyreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.13.5 when convenient.

Data as of 3 Nov 2026, 16:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.16.1
Patch
Available – fixed in 0.13.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade texlyre to 0.13.5.

Affected software

ProductAffectedFixed in
TeXlyretexlyreAffected
  • >=0.11.0 <0.13.5
Fixed in
  • 0.13.5
GitHubtexlyrepkg:github/texlyreOther threatsAffected
  • >=0.11.0 <0.13.5
Fixed in
  • 0.13.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade TeXlyre to version 0.13.5 or later, where this vulnerability is fixed. No other mitigation actions are indicated by the vendor advisory.

Description

TeXlyre versions from 0.11.0 up to but not including 0.13.5 contain a stored cross-site scripting (XSS) vulnerability. This flaw allows attackers to execute malicious scripts by supplying crafted LSP or typesetter recipe icons containing HTML event handlers. Successful exploitation can lead to persistent script execution in victims' environments, potentially exposing local projects and repository credentials. The vulnerability is fixed in version 0.13.5.

References

Community reviews

Loading reviews…