Skip to main content
VulnerabilityPublished

CVE-2026-121624: Nanosystems Supremo · Improper Certificate Validation

Affects Nanosystems SupremoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 5.0.2.3874 soon.

Data as of 3 Nov 2026, 17:30 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.6
CNA (VulnCheck)CVSS 3.16.8
Patch
Available – fixed in 5.0.2.3874
CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Nanosystems Supremo to 5.0.2.3874.

Affected software

ProductAffectedFixed in
NanosystemsSupremoAffected
  • <5.0.2.3874
Fixed in
  • 5.0.2.3874

AI-suggested

Upgrade Nanosystems Supremo to version 5.0.2.3874 or later, where the improper certificate validation vulnerability has been fixed. No other mitigation is indicated by the vendor advisory.

Description

Nanosystems Supremo versions before 5.0.2.3874 for Windows and macOS have an improper certificate validation vulnerability. This flaw allows attackers on the same network to intercept TLS connections by using self-signed certificates. Exploitation can lead to exposure of usernames, SHA-256 password hashes, and license codes. The vulnerability is fixed in version 5.0.2.3874.

References

Community reviews

Loading reviews…