CVE-2026-121762: PowerPress Podcasting (WordPress plugin) · Cross-Site Request Forgery (CSRF)
Affects PowerPress Podcasting (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 11.18.2 soon.
Data as of 7 Nov 2026, 09:34 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 11.18.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade PowerPress Podcasting (WordPress plugin) to 11.18.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PowerPress Podcastingpowerpress | Affected
| Fixed in
|
AI-suggested
Upgrade PowerPress Podcasting to version 11.18.2 or later to apply the official fix for this CSRF vulnerability. No other mitigation is required once the patch is applied.
Description
CVE-2026-121762 is a Cross-Site Request Forgery (CSRF) vulnerability affecting Blubrry Podcasting's PowerPress Podcasting plugin. The flaw allows an attacker to perform unauthorized actions on behalf of an authenticated user. Versions from initial releases up to 11.18.0 are affected. The issue is resolved in version 11.18.2.