CVE-2026-121765: TranslatePress (WordPress plugin) · Cross-site Scripting
Affects TranslatePress (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 3.3.9 soon.
Data as of 7 Nov 2026, 12:20 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 7.1 |
|---|
- Patch
- Available – fixed in 3.3.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade TranslatePress (WordPress plugin) to 3.3.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TranslatePresstranslatepress-multilingual | Affected
| Fixed in
|
AI-suggested
Upgrade TranslatePress to version 3.3.9 or later, where this vulnerability has been fixed. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2026-121765 is a stored cross-site scripting (XSS) vulnerability in Cozmoslabs TranslatePress plugin versions up to 3.3.8. It arises from improper neutralization of input during web page generation, allowing attackers to inject malicious scripts. The vulnerability is fixed in version 3.3.9.