Skip to main content
VulnerabilityPublished

CVE-2026-121928: InfiniFlow RAGFlow · Cross-site Scripting

Affects InfiniFlow RAGFlowSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium · fixed in 0.27.3 : patch InfiniFlow RAGFlow as a priority.

Data as of 4 Nov 2026, 20:51 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.1
CNA (VulDB)CVSS 3.13.5
CNA (VulDB)CVSS 3.03.5
CNA (VulDB)CVSS 2.04.0
Patch
Available – fixed in 0.27.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
InfiniFlowRAGFlowAffected
  • =0.27.0
  • =0.27.1
  • =0.27.2
Fixed in–
GitHubinfiniflow/ragflowpkg:github/infiniflow/ragflowOther threatsAffected
  • =0.27.0
  • =0.27.1
  • =0.27.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:infiniflow:ragflow:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade InfiniFlow RAGFlow to version 0.27.3 or later, which contains the official fix for this vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-121928 is a cross-site scripting (XSS) vulnerability in InfiniFlow RAGFlow versions 0.27.0 through 0.27.2. The flaw exists in the Images API component, specifically in the file api/utils/file_utils.py, allowing remote attackers to execute XSS attacks. A public exploit is available. Upgrading to version 0.27.3 addresses this issue.

References

Community reviews

Loading reviews…