Skip to main content
VulnerabilityPublished

CVE-2026-121936: cosin2077 easyVoice · Server-Side Request Forgery (SSRF)

Affects cosin2077 easyVoiceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.0.23 when convenient.

Data as of 4 Nov 2026, 12:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 0.0.23
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade cosin2077 easyVoice to 0.0.23.

Affected software

ProductAffectedFixed in
cosin2077easyVoiceAffected
  • <0.0.23
Fixed in
  • 0.0.23
GitHubeasyVoicepkg:github/easyVoiceOther threatsAffected
  • <0.0.23
Fixed in
  • 0.0.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade easyVoice to version 0.0.23 or later, where this SSRF vulnerability is fixed. No other mitigation is indicated or required according to the available information.

Description

CVE-2026-121936 is a server-side request forgery (SSRF) vulnerability in cosin2077 easyVoice versions before 0.0.23. It allows unauthenticated attackers to make the server send POST requests by manipulating the openaiBaseUrl parameter when useLLM is enabled. Attackers can exploit this to target internal and loopback services via the /api/v1/tts endpoint and use reflected error messages in the x-generate-tts-warning header to probe internal hosts and ports. The vulnerability has a CVSS 4.0 base score of 6.9 (medium severity). A fix is available in version 0.0.23.

References

Community reviews

Loading reviews…