Skip to main content
VulnerabilityPublished

CVE-2026-122006: rubyonrails Active Storage · Insecure Default

Affects rubyonrails Active StorageSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 8.1.4.1 or 8.0.5.2 as a priority.

Data as of 4 Nov 2026, 14:43 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.19.8
Patch
Available – fixed in 8.1.4.1, 8.0.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade rubyonrails Active Storage to 8.1.4.1 or 8.0.5.2.

Affected software

ProductAffectedFixed in
rubyonrailsActive StorageAffected
  • >=8.1 <8.1.4.1
Fixed in
  • 8.1.4.1
rubyonrailsActive StorageAffected
  • <8.0.5.2
Fixed in
  • 8.0.5.2
RubyGemsActive Storagepkg:gem/Active StorageOther threatsAffected
  • <8.0.5.2
  • >=8.1 <8.1.4.1
Fixed in
  • 8.0.5.2
  • 8.1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade activestorage to version 8.0.5.2 or 8.1.4.1 or later where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Applying the official patch is the recommended remediation.

Description

CVE-2026-122006 is a critical vulnerability in the Ruby on Rails activestorage gem before versions 8.0.5.2 and 8.1.4.1. It arises when ImageMagick is used for attachment processing without a proper security policy, allowing the ImageMagick analyzer to execute unintended operations. This can lead to unauthorized server read and write access, including exposure of sensitive data such as secret_key_base.

References

Community reviews

Loading reviews…