Skip to main content
VulnerabilityPublished

CVE-2026-122140: germondai trawl · Server-Side Request Forgery (SSRF)

Affects germondai trawlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.10.0 when convenient.

Data as of 4 Nov 2026, 21:42 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.15.8
Patch
Available – fixed in 1.10.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade germondai trawl to 1.10.0.

Affected software

ProductAffectedFixed in
germondaitrawlAffected
  • >=1.5.0 <1.10.0
Fixed in
  • 1.10.0
GitHubtrawlpkg:github/trawlOther threatsAffected
  • >=1.5.0 <1.10.0
Fixed in
  • 1.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Trawl version 1.10.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

Trawl versions from 1.5.0 up to but not including 1.10.0 contain a server-side request forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to bypass the outbound URL policy by using IPv4-mapped IPv6 addresses, enabling them to access internal resources such as loopback, private networks, and cloud metadata services. The vulnerability is fixed in version 1.10.0.

References

Community reviews

Loading reviews…