Skip to main content
VulnerabilityPublished

CVE-2026-122151: Presenton · Cross-Site Request Forgery

Affects PresentonSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium · fixed in 0.9.12 : patch Presenton as a priority.

Data as of 5 Nov 2026, 01:42 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.14.3
CNA (VulDB)CVSS 3.04.3
CNA (VulDB)CVSS 2.05.0
Patch
Available – fixed in 0.9.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
PresentonAffected
  • =0.9.11-beta
Fixed in–
GitHubpresenton/presentonpkg:github/presenton/presentonOther threatsAffected
  • <=0.9.11-beta
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:presenton:presenton:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Presenton to version 0.9.12-beta, which contains the official fix for this vulnerability. Applying this update will remediate the CSRF issue in the User Configuration Handler component. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-122151 is a cross-site request forgery (CSRF) vulnerability in Presenton versions up to 0.9.11-beta. It affects the JSON.parse function in the /api/user-config endpoint of the User Configuration Handler component. The vulnerability allows remote attackers to manipulate user configuration via CSRF attacks. Public exploit code has been disclosed. Upgrading to version 0.9.12-beta addresses this issue.

References

Community reviews

Loading reviews…