Skip to main content
VulnerabilityPublished

CVE-2026-122158: InvoiceShelf · Improper Access Controls

Affects InvoiceShelfSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium.

Data as of 5 Nov 2026, 02:30 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.1
CNA (VulDB)CVSS 3.14.7
CNA (VulDB)CVSS 3.04.7
CNA (VulDB)CVSS 2.05.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
InvoiceShelfAffected
  • 2.4.0 – 3.0.0-alpha.3
8 affected builds
Fixed in–
GitHubinvoiceshelf/InvoiceShelfpkg:github/invoiceshelf/InvoiceShelfOther threatsAffected
  • 2.4.0 – 3.0.0-alpha.3
8 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:invoiceshelf:invoiceshelf:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade InvoiceShelf to version 2.4.4 or 3.0.0-alpha.4, where the vulnerability has been fixed. Applying this official patch fully mitigates the risk. No additional mitigation steps are indicated by the vendor.

Description

CVE-2026-122158 is a medium severity vulnerability in InvoiceShelf versions up to 2.4.3 and 3.0.0-alpha.3. It involves improper access controls in the MemberService::create function, allowing remote attackers to manipulate company ID and role parameters. Public exploit code is available. Upgrading to versions 2.4.4 or 3.0.0-alpha.4 resolves the issue.

References

Community reviews

Loading reviews…