Skip to main content
VulnerabilityPublished

CVE-2026-122319: kyverno · Incorrect Type Conversion or Cast

Affects kyvernoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.19.2 soon.

Data as of 5 Nov 2026, 02:58 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
kyvernokyvernoAffected
  • <1.19.2
Fixed in
  • 1.19.2

AI-suggested

Upgrade Kyverno to version 1.19.2 or later, where this vulnerability is fixed. No other mitigations are indicated or required as the fix is available.

Description

Kyverno versions before 1.19.2 have a denial-of-service vulnerability in the In and NotIn operators caused by an unchecked type assertion. This flaw allows attackers to crash the policy engine by submitting resources with JMESPath-evaluated values that are arrays of integers, booleans, or mixed types, leading to a panic that disrupts admission control and policy enforcement.

References

Community reviews

Loading reviews…