Skip to main content
VulnerabilityPublished

CVE-2026-123202: bakulf libnxml · Stack-based Buffer Overflow

Affects bakulf libnxmlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 0.18.6 soon.

Data as of 5 Nov 2026, 20:17 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 0.18.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade bakulf libnxml to 0.18.6.

Affected software

ProductAffectedFixed in
bakulflibnxmlAffected
  • <0.18.6
Fixed in
  • 0.18.6
GitHublibnxmlpkg:github/libnxmlOther threatsAffected
  • <0.18.6
Fixed in
  • 0.18.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libnxml to version 0.18.6 or later, where this stack-based buffer overflow vulnerability is fixed. No other mitigation or workaround is indicated.

Description

libnxml versions before 0.18.6 have a stack-based buffer overflow vulnerability in the nxml_parser.c source file. This flaw allows remote attackers to cause a crash or potentially execute code by supplying XML or RSS feeds with very long element, attribute, DOCTYPE, or entity names (up to 1022 characters) ending with a multi-byte UTF-8 character. The vulnerability is fixed in version 0.18.6.

References

Community reviews

Loading reviews…