Skip to main content
VulnerabilityPublished

CVE-2026-123495: vikunja · Cross-Site Request Forgery (CSRF)

Affects vikunjaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.7.1 when convenient.

Data as of 8 Nov 2026, 02:32 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.1
CNA (VulnCheck)CVSS 3.14.6
Patch
Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade vikunja to 2.7.1.

Affected software

ProductAffectedFixed in
go-vikunjavikunjaAffected
  • >=2.0.0 <2.7.1
Fixed in
  • 2.7.1
Govikunjapkg:golang/vikunjaOther threatsAffected
  • >=2.0.0 <2.7.1
Fixed in
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Vikunja to version 2.7.1 or later, where this CSRF vulnerability has been fixed. No other mitigations are specified or required once the official fix is applied.

Description

Vikunja versions 2.0.0 up to but not including 2.7.1 are vulnerable to a Cross-Site Request Forgery (CSRF) attack on the /api/v2 login and OIDC callback endpoints. These endpoints accept form-encoded bodies without verifying CSRF tokens or Origin headers, allowing an attacker with an account to trick a victim into switching to the attacker's account. This can expose data the victim subsequently adds. The vulnerability is fixed in version 2.7.1.

References

Community reviews

Loading reviews…