CVE-2026-123535: tornadoweb tornado · Injection
Affects tornadoweb tornadoSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 6.6 when convenient.
Data as of 8 Nov 2026, 02:18 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.2 |
- Patch
- Available – fixed in 6.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade tornadoweb tornado to 6.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| tornadowebtornado | Affected
| Fixed in
|
PyPItornadopkg:pypi/tornadoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tornado to version 6.6 or later where this vulnerability is fixed. No other mitigation is required as the issue is resolved in the official patch.
Description
CVE-2026-123535 is a vulnerability in Tornado versions before 6.6 where the max_age argument of RequestHandler.set_cookie and related methods is not properly validated. This flaw allows an attacker to inject additional Set-Cookie attributes such as Domain, Path, or Secure by supplying attacker-controlled input as max_age, potentially expanding the cookie's scope to parent paths or other subdomains. The issue is fixed in Tornado 6.6.