CVE-2026-123566: sveltejs devalue · Uncontrolled Resource Consumption
Affects sveltejs devalueSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 5.9.3 soon.
Data as of 8 Nov 2026, 02:05 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 5.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade sveltejs devalue to 5.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| sveltejsdevalue | Affected
| Fixed in
|
npmdevaluepkg:npm/devalueOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade sveltejs devalue to version 5.9.3 or later, where this vulnerability is fixed. No additional mitigations are indicated.
Description
Sveltejs devalue versions before 5.9.3 contain a denial of service vulnerability where attackers can cause CPU amplification by supplying sparse arrays to the uneval function. This forces synchronous work proportional to the declared array length, blocking the event loop and potentially causing application unavailability.