Skip to main content
VulnerabilityPublished

CVE-2026-123573: hickory-dns · Improper Input Validation

Affects hickory-dnsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 0.26.2 soon.

Data as of 8 Nov 2026, 02:04 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 0.26.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade hickory-dns to 0.26.2.

Affected software

ProductAffectedFixed in
hickory-dnshickory-dnsAffected
  • >=0.20.1 <0.26.2
Fixed in
  • 0.26.2
crates.iohickory-dnspkg:cargo/hickory-dnsOther threatsAffected
  • >=0.20.1 <0.26.2
Fixed in
  • 0.26.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade hickory-dns to version 0.26.2 or later, where this vulnerability is fixed. No other mitigation steps are indicated.

Description

CVE-2026-123573 is a denial of service vulnerability in hickory-dns versions from 0.20.1 up to but not including 0.26.2. The flaw exists in the hickory-proto SVCB and HTTPS record presentation format parser, where specially crafted zone files containing a single or double quote replacing a service parameter value cause a panic that crashes the parser. This vulnerability has a high severity rating with a CVSS score of 8.7. It is fixed in version 0.26.2.

References

Community reviews

Loading reviews…