CVE-2026-123591: hickory-dns · Insufficient Verification of Data Authenticity
Affects hickory-dnsSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 0.26.2 soon.
Data as of 8 Nov 2026, 02:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 0.26.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade hickory-dns to 0.26.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hickory-dnshickory-dns | Affected
| Fixed in
|
| hickory-dnshickory-dns | Affected
| Fixed in– |
crates.iohickory-dnspkg:cargo/hickory-dnsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Hickory DNS to version 0.26.2 or later, where this vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-123591 is a vulnerability in Hickory DNS affecting versions 0.26.0-beta.1 through before 0.26.2 and hickory-proto through 0.26.0-alpha.1. The software fails to verify that an NSEC or NSEC3 record denying a DS RRset also proves the delegation's NS record exists, as required by RFC 6840 §4.4. This flaw allows attackers to reuse child-side NSEC or NSEC3 records to fake an insecure delegation and forge child-zone records. A fix is available in version 0.26.2. The vulnerability has a high severity with a CVSS 4.0 score of 8.2.