Skip to main content
VulnerabilityPublished

CVE-2026-123617: openwhyd · Improper Neutralization of Special Elements in Data Query Logic

Affects openwhydSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.65.1 when convenient.

Data as of 6 Nov 2026, 15:25 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 1.65.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade openwhyd to 1.65.1.

Affected software

ProductAffectedFixed in
openwhydopenwhydAffected
  • <1.65.1
Fixed in
  • 1.65.1
GitHubopenwhydpkg:github/openwhydOther threatsAffected
  • <1.65.1
Fixed in
  • 1.65.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade openwhyd to version 1.65.1 or later, where this vulnerability is fixed. No other mitigation steps are indicated or required.

Description

Openwhyd versions prior to 1.65.1 contain a NoSQL injection vulnerability that allows unauthenticated attackers to manipulate user lookup queries by injecting MongoDB operators in the id parameter. This flaw enables attackers to enumerate other users' public profile records via crafted POST requests to /api/user. The vulnerability is fixed in version 1.65.1.

References

Community reviews

Loading reviews…