Skip to main content
VulnerabilityPublished

CVE-2026-123746: sensiolabs symfony · Authentication Bypass Using an Alternate Path or Channel

Affects sensiolabs symfonySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low · fixed in 8.1.11 : update sensiolabs symfony when convenient.

Data as of 6 Nov 2026, 13:02 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmarx)CVSS 4.02.3
Patch
Available – fixed in 8.1.11, 7.4.23, 6.4.50 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade symfony and symfony/security-http to 8.1.11, 7.4.23, 6.4.50 or 5.4.56.

Affected software

ProductAffectedFixed in
symfonysymfony/security-httpAffected
  • >=8.0.0 <8.1.11
Fixed in
  • 8.1.11
symfonysymfony/security-httpAffected
  • >=7.0.0 <7.4.23
Fixed in
  • 7.4.23
symfonysymfony/security-httpAffected
  • >=6.0.0 <6.4.50
Fixed in
  • 6.4.50
symfonysymfony/security-httpAffected
  • <5.4.56
Fixed in
  • 5.4.56
Packagistsymfony/security-httppkg:composer/symfony/security-httpOther threatsAffected
  • <5.4.56
  • >=6.0.0 <6.4.50
  • >=7.0.0 <7.4.23
  • >=8.0.0 <8.1.11
Fixed in
  • 5.4.56
  • 6.4.50
  • 7.4.23
  • 8.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Symfony to version 5.4.56, 6.4.50, 7.4.23, 8.1.11 or later, where the vulnerability is fixed by dispatching the security.authentication.success event during programmatic authentication to run checkPostAuth(). No other mitigation is required as the fix is official and available.

Description

CVE-2026-123746 is an authentication bypass vulnerability in the Symfony Security HTTP component affecting versions prior to 5.4.56, 6.4.50, 7.4.23, and 8.1.11. The flaw occurs because the AuthenticatorManager::authenticateUser() method does not invoke the firewall user checker's checkPostAuth() method when users are authenticated programmatically. This allows accounts rejected by custom user checkers in checkPostAuth(), such as expired accounts, to be authenticated via programmatic flows like password resets or email verification. The default user checker is not affected. The issue is fixed by dispatching the security.authentication.success event to trigger checkPostAuth() during programmatic authentication.

References

Community reviews

Loading reviews…