Skip to main content
VulnerabilityPublished

CVE-2026-124441: kyverno · Incorrect Authorization

Affects kyvernoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.19.2 soon.

Data as of 8 Nov 2026, 13:49 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
kyvernokyvernoAffected
  • <1.19.2
Fixed in
  • 1.19.2
Gokyvernopkg:golang/kyvernoOther threatsAffected
  • <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kyverno to version 1.19.2 or later, where this authorization bypass vulnerability is fixed. No other mitigations are indicated.

Description

Kyverno versions before 1.19.2 have an authorization bypass vulnerability that allows namespaced tenants to create resources of any kind in any namespace by manipulating generate rule templates. This can lead to attackers creating policies that cause the privileged background-controller to write sensitive resources such as NetworkPolicies or RoleBindings into namespaces they should not control, including kube-system. The vulnerability is fixed in version 1.19.2.

References

Community reviews

Loading reviews…