CVE-2026-12696: wpForo Forum (WordPress plugin) · Cross-Site Scripting (XSS)
Affects wpForo Forum (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.1.2 when convenient.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade wpForo Forum (WordPress plugin) to 3.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpForo Forum | Affected
| Fixed in
|
AI-suggested
Since the vulnerability affects versions before 3.1.2, upgrading to version 3.1.2 or later is likely recommended once confirmed by the vendor. Until then, restrict subscriber-level user capabilities or monitor for suspicious profile content as a temporary measure.
Description
The wpForo Forum WordPress plugin before 3.1.2 does not sanitize and escape a user profile field before outputting it inside an HTML attribute on the public participant profile page, allowing users with a subscriber-level account to inject JavaScript that executes in the browser of any visitor who views the profile, including a logged-in administrator.