Skip to main content
VulnerabilityPublished

CVE-2026-12721: Kirki (WordPress plugin) · SQL Injection

Affects Kirki (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 6.0.13 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Kirki (WordPress plugin) to 6.0.13.

Affected software

ProductAffectedFixed in
KirkiAffected
  • <6.0.13
Fixed in
  • 6.0.13

AI-suggested

If you cannot patch yet, users should consider disabling the Kirki plugin or restricting access to vulnerable endpoints to mitigate risk. Avoid exposing the plugin to untrusted users or public access where possible.

Description

CVE-2026-12721 is a high-severity SQL injection vulnerability in the Kirki WordPress plugin versions before 6.0.13. The plugin fails to properly sanitize and escape user-supplied input used in SQL queries, allowing unauthenticated attackers to perform SQL injection. This vulnerability can lead to unauthorized access to sensitive data.

References

Community reviews

Loading reviews…